Content inset not working Storyboard Xcode8

Recently I have updated Xcode 7.3 to 8. While opening the project the project settings also have been updated for new Xcode.

Now the insets given for a button image for positioning the image inside button frame is not working as in previous Xcode(7.3) version.

  • How can I capture an image from iOS camera without user interaction?
  • UIImageJPEGRepresentation returns nil
  • Parse request.object.get(“KEY”) always returns undefined
  • How to get the user's current location by code in iphone app?
  • Plist Array to NSArray no objects
  • Xcode 4 / iOS - Send an email using SMTP from inside my app
  • The image insets are given through storyboard. Image was used here to have large clickable area for button than the button image display area. Is there any other options to get it through storyboard.

    enter image description here

    5 Solutions Collect From Internet About “Content inset not working Storyboard Xcode8”

    In Xcode 8 the button content/title/image insets have moved to the Size Inspector tab:

    Which seems quite logical by the way! 😀

    I had this same problem and solved it with image insets and the Horizontal/Vertical Alignment controls. My problem was that I had the wrong alignment controls selected. Once I changed it my insets worked properly for what I was trying to accomplish.

    I created a button with an image and the I wanted to shrink the image down to not fill up the entire button So I set the image to the UIButton image property in storyboard and then set the image insets to my liking

    enter image description here

    But it did not center my image with the inset of 5 on each side. The image would look like this and that was not what I wanted

    enter image description here

    If you change the horizontal/vertical alignment controls I was able to the button image to my desired look I wanted

    enter image description here

    Its weird,but it actually works until you add collectionview or tableview in your Viewcontroller. Try setting the inset without having the scrollview or tableview in your view controller

    There is a weird behavior when having a UITableView or UIScrollView on the scene (as mentioned by @RAHUL JOSHI). Sample

    Solution: Just ignore the previsualization bug as on runtime this will work normally.

    Content inset for button is working perfect in xcode 8 beta.
    See below screenshot that i have taken from xcode8 beta.

    enter image description here