Google Maps iOS SDK Integration not loading maps

I am using Google maps iOS SDK in my iPhone application. I am showing a place mark on the map and it is working fine in my iPhone device using my apple developer account certificates. But when i sent build to testing team using a different Enterprise Apple developer account certificates(Enterprise account), the maps are not loading up, it only shows the Place mark on a blank screen with the maps loading up.

I have also tried on my iPhone devices with the enterprise apple developer account, and it is not loading the map(Just a Pin on blank screen). But with my own apple developer account certificates, it is working absolutely fine.

  • How to make NSDate with associative object work?
  • Custom map style in MapKit
  • “This application is modifying the autolayout engine from a background thread”
  • Custom table view cell: IBOutlet label is nil
  • Error when I'm using MailCore2 in Swift 2
  • Why is a single threaded model used to update the UI as main thread?
  • I am assuming that the problem is in Enterprise Apple developer account(Might be i have change some settings on Apple developer account for my App Id). I am not able to find out a solution for this.

    Can anybody help me out on this? If you need more information on this , please ask me in a comment.

    Thanks in Advance!

    Solutions Collect From Internet About “Google Maps iOS SDK Integration not loading maps”

    Typically this will happen if you don’t have the app bundle id added to your google APIs console. The bundle id (eg., com.myname.appname) is what google uses to verify that an app is allowed to use a certain api key. If you’ve moved your app from one developer account to another, you’ve probably changed the bundle id in the process. Fortunately, google allows you to associate multiple bundle ids with a single api key.

    To add a new bundle id:

    • Verify the bundle id you are using in xcode (select the target and look under summary)
    • Login to https://code.google.com/apis/console/
    • Select “API Access” on the left column
    • Select “Edit allowed iOS apps” under the “key for iOS apps” section
    • Add the bundle id used in the enterprise build