Install old cocoapods?

My entire project is wack currently because none of the dependencies are compliant with cocoapods 1.0. Not only are millions of Podspecs not working, there are also multiple other issues which used to be warnings and are now build halting errors… so frustrating.

I have tried removing ~/.cocoapods, sudo gem uninstall cocoapods and sudo gem install cocoapods -v 0.39.0 and the same errors are occurring. It looks like it’s installing it anyway or something?

  • can't setup ruby environment - installing fii gem error
  • The compiler failed to generate an executable file. (RuntimeError)
  • cocoapods (0.39.0)
    cocoapods-core (1.0.0, 0.39.0)
    cocoapods-deintegrate (1.0.0)
    cocoapods-downloader (1.0.0, 0.9.3)
    cocoapods-plugins (1.0.0, 0.4.2)
    cocoapods-search (1.0.0, 0.1.0)
    cocoapods-stats (1.0.0, 0.6.2)
    cocoapods-trunk (1.0.0, 0.6.4)
    cocoapods-try (1.0.0, 0.5.1)
    

    How do I use 100% old version until these libs are fixed?

    Solutions Collect From Internet About “Install old cocoapods?”

    Step 1 Run sudo gem install cocoapods -v 0.39.0, this will install the version you want.

    Step 2 Run sudo gem list, which will give you a list of all the gems you have installed as well as their version; you’ll note that you have multiple versions of cocoapods installed.

    Step 3 Uninstall the version(s) you don’t want with sudo gem uninstall cocoapods -v 1.0.

    Step 4 Confirm you are now running the correct version of cocoapods with pod --version.