iOS Simulator cannot start

I have upgraded my Mac to OS X El Capitan (version 10.11.4) and updated Xcode (version 7.3 (7D175)). I’m working on Xamarin (version 5.10.3 (build 27)). I get all iOS Simulator components (from Xcode Preferences/Components), versions 8.1, 8.2, 8.3, 8.4, 9.0, 9.1 and 9.2, no version 9.3 available..

After all upgrades and a restart I open my project in Xamarin and launch it and an error message raise to say that the iOS Simulator cannot start. I tried to create a new project on Xcode (to see if it was related to Xamarin), tried to launch it and the same issue occurs.

  • Saving WebView to PDF returns blank image?
  • Firebase Notification Integration on cocoa os x application
  • How to custom draw window title bar in Objective-C?
  • Unable to build mercurial on OSX - Python.h not found
  • How to open Xcode project which has objectVersion 38 with Xcode 4.3.2
  • Qt Creator - Project ERROR: Xcode not set up properly. You may need to confirm the license agreement by running /usr/bin/xcodebuild
  • This is the crash report:

    Process:               Simulator [1497]
    Path:                  /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator
    Identifier:            com.apple.iphonesimulator
    Version:               ???
    Build Info:            Indigo-645009000000000~27
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           Simulator [1497]
    User ID:               1283659680
    
    Date/Time:             2016-03-31 10:53:04.204 +0200
    OS Version:            Mac OS X 10.11.4 (15E65)
    Report Version:        11
    Anonymous UUID:        5CBF8D9C-B1CD-87AC-FF01-AD5337903E26
    
    
    Time Awake Since Boot: 2300 seconds
    
    System Integrity Protection: enabled
    
    Crashed Thread:        0
    
    Exception Type:        EXC_BREAKPOINT (SIGTRAP)
    Exception Codes:       0x0000000000000002, 0x0000000000000000
    Exception Note:        EXC_CORPSE_NOTIFY
    
    Application Specific Information:
    dyld: launch, loading dependent libraries
    
    Dyld Error Message:
    Library not loaded: /usr/local/lib/libwep
    Referenced from: /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator
    Reason: no suitable image found.  Did find:
    /usr/local/lib/libwep: mmap() error 1 at address=0x10DEC0000, size=0x00008000 segment=__TEXT in Segment::map() mapping /usr/local/lib/libwep
    
    Binary Images:
    0x7fff6dae7000 -     0x7fff6db1e0d7  dyld (360.21) <D9B236BC-4AC1-325F-B3EF-3F06DBDA7119> /usr/lib/dyld
    0x7fff8b48d000 -     0x7fff8b502fff  com.apple.framework.IOKit (2.0.2 - 1179.40.20) <FB2AD43B-905D-3BD0-BE17-ACE7D4D13E24> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
    0x7fff8b995000 -     0x7fff8bd00657  libobjc.A.dylib (680) <D55D5807-1FBE-32A5-9105-44D7AFE68C27> /usr/lib/libobjc.A.dylib
    0x7fff8c4f6000 -     0x7fff8c6c4ff3  com.apple.QuartzCore (1.11 - 410.14) <0283748A-8318-36AC-8B30-8A951FEB305A> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
    0x7fff8e1d1000 -     0x7fff8e1f9fff  com.apple.GLKit (1.0 - 56) <E5E5A6F0-E6FC-3D40-81E4-A3E627929FD0> /System/Library/Frameworks/GLKit.framework/Versions/A/GLKit
    0x7fff904f8000 -     0x7fff904f8fff  com.apple.Carbon (154 - 157) <8F6ED602-5943-3E29-A793-BC331E2C183D> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
    0x7fff93d01000 -     0x7fff93d02ffb  libSystem.B.dylib (1226.10.1) <CD307E99-FC5C-3575-BCCE-0C861AA63124> /usr/lib/libSystem.B.dylib
    0x7fff9583f000 -     0x7fff95cb5fff  com.apple.CoreFoundation (6.9 - 1258.1) <943A1383-DA6A-3DC0-ABCD-D9AEB3D0D34D> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x7fff96177000 -     0x7fff96179fff  com.apple.xpc.ServiceManagement (1.0 - 1) <F3E14561-5DF4-3429-98ED-8F27A87A343A> /System/Library/Frameworks/ServiceManagement.framework/Versions/A/ServiceManagement
    0x7fff9a5d3000 -     0x7fff9a5e1fff  com.apple.opengl (12.0.40 - 12.0.40) <AEA28993-BA3E-3E0F-A2F5-88C312ABB634> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
    0x7fff9ac23000 -     0x7fff9b84cfff  com.apple.AppKit (6.9 - 1404.46) <2492D315-76B6-320B-B542-231FCA44CA48> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
    0x7fff9cf39000 -     0x7fff9d28dfff  com.apple.Foundation (6.9 - 1258) <51833143-6CAE-3E1C-9FBA-BCDEB48D4ADF> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x7fff9e27d000 -     0x7fff9f4e5ffb  com.apple.CoreGraphics (1.600.0 - 957) <C403FF5C-1B6F-3810-90B1-F5477828A701> /System/Library/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
    0x7fffa02a8000 -     0x7fffa02ccfff  com.apple.MultitouchSupport.framework (304.10.2 - 304.10.2) <CE75EDA3-2B22-3968-834E-550EA870ECC8> /System/Library/PrivateFrameworks/MultitouchSupport.framework/Versions/A/MultitouchSupport
    0x7fffa1542000 -     0x7fffa1882fff  com.apple.WebKit (11601 - 11601.5.17.1) <6FA46AD7-3DF1-3654-A642-D9C5BE613ED7> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
    

    I don’t understand why the /usr/local/lib/libwep library is not loading.
    There is no explicit message or information to understand the issue and try to fix it. I do not find a lot help on similar issues.

    I tried this solution, but it just removed the iOS Simulator components that I just download with Xcode.

    I need help, if you have any ideas, as I can’t debug anymore until this simulator will start.

    Solutions Collect From Internet About “iOS Simulator cannot start”

    The issue is caused by your use of WebSense. This software injects a library (usr/local/lib/libwep) into every process, and that practice is not valid for processes utilizing library validation for increased security. Simulator.app is one such process that is making use of library validation.

    You need to reach out to WebSense for a compatible update to their software.