This iPhone 6 is running iOS 10.1 (14B55c), which may not be supported by this version of Xcode

4 Solutions Collect From Internet About “This iPhone 6 is running iOS 10.1 (14B55c), which may not be supported by this version of Xcode”

To use the iOS 10.1 beta you need to use the Xcode 8.1 beta. Xcode 8 doesn’t support the iOS 10.1 beta.

And now since iOS 10.1 and Xcode 8.1 are out of beta, be sure you update to the latest, non-beta of both.

Update Xcode 8.1 is now available on the app store, so you should just update your Xcode to the latest: https://itunes.apple.com/us/app/xcode/id497799835?mt=12


It looks like iOS 10.1 was released today, but not Xcode 8.1. If you upgraded your devices to 10.1, you’ll need to download the Xcode 8.1 GM Seed in order to deploy to your devices running iOS 10.1.

You can download the 8.1 GM Seed here: https://developer.apple.com/download/

GM Seed’s are typically the final version that gets released to the app store.

The public Xcode 8 release does not support iOS 10.1 beta. Apple released beta builds of macOS Sierra 10.12.1 and iOS 10.1 a few days ago. But watchOS, tvOS and Xcode are not included in Apple’s public betas.

You need Xcode 8.1 GM to use your 10.1 device. BUT it’s really absurd to release a new iOS version without releasing the respective Xcode version. Something really weird.