Xcode 7 beta 2: LaunchScreen.storyboard could not open document

I am getting this error on two different Macs (iMac and Mac Book pro). No idea why people can’t reproduce it but I need some help.

enter image description here

  • Basics Introduction To Using CHCSVParser
  • iOS 7.0 and ARC: UITableView never deallocated after rows animation
  • Simplified asserts in OCUnit
  • Determine whether app is communicating with APNS sandbox or production environment
  • How do I include libxslt in my iPhone app?
  • How to extract emojis from a string?
  • I am running Xcode 7 beta 2 (23 June ’15) on a Mac running OS X Yosemite 10.10.4.

    Can’t even compile and run my project..

    I created a single view application project from the create menu, and that’s it.

    EDIT:

    I tried to delete and re-add the storyboard file (also the Main.storyboard cannote be opened) and I still get the same message. This is the crash report:

    Process:               com.apple.CoreSimulator.CoreSimulatorService [2316]
    Path:                  /Applications/Xcode-beta.app/Contents/Developer/Library/PrivateFrameworks/CoreSimulator.framework/Versions/A/XPCServices/com.apple.CoreSimulator.CoreSimulatorService.xpc/Contents/MacOS/com.apple.CoreSimulator.CoreSimulatorService
    Identifier:            com.apple.CoreSimulator.CoreSimulatorService
    Version:               ???
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           com.apple.CoreSimulator.CoreSimulatorService [2316]
    User ID:               489132888
    
    Date/Time:             2015-07-08 11:47:46.022 +0100
    OS Version:            Mac OS X 10.10.4 (14E11f)
    Report Version:        11
    Anonymous UUID:        --value--
    
    
    Time Awake Since Boot: 7500 seconds
    
    Crashed Thread:        0
    
    Exception Type:        EXC_BREAKPOINT (SIGTRAP)
    Exception Codes:       0x0000000000000002, 0x0000000000000000
    
    Application Specific Information:
    dyld: launch, loading dependent libraries
    
    Dyld Error Message:
      Library not loaded: /usr/lib/libwep
      Referenced from: /Applications/Xcode-beta.app/Contents/Developer/Library/PrivateFrameworks/CoreSimulator.framework/Versions/A/XPCServices/com.apple.CoreSimulator.CoreSimulatorService.xpc/Contents/MacOS/com.apple.CoreSimulator.CoreSimulatorService
      Reason: no suitable image found.  Did find:
        /usr/lib/libwep: mmap() error 1 at address=0x105FB8000, size=0x00003000 segment=__TEXT in Segment::map() mapping /usr/lib/libwep
        /usr/lib/libwep: mmap() error 1 at address=0x105FBF000, size=0x00003000 segment=__TEXT in Segment::map() mapping /usr/lib/libwep
    
    Binary Images:
        0x7fff6a06c000 -     0x7fff6a0a2837  dyld (353.2.1) <72A99D0F-0B56-3938-ABC5-67A0F33757C4> /usr/lib/dyld
        0x7fff843dd000 -     0x7fff8470efff  com.apple.Foundation (6.9 - 1153.20) <F0FF3A5D-C5B7-34A1-9319-DE1EF928E58E> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
        0x7fff89079000 -     0x7fff89411ff7  com.apple.CoreFoundation (6.9 - 1153.18) <5C0892B8-9691-341F-9279-CA3A74D59AA0> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
        0x7fff8944a000 -     0x7fff8944bff3  libSystem.B.dylib (1213) <17F6DDBE-8FDC-3DD5-8562-76618A81CFE6> /usr/lib/libSystem.B.dylib
        0x7fff8d2f1000 -     0x7fff8d4eb46f  libobjc.A.dylib (647) <759E155D-BC42-3D4E-869B-6F57D477177C> /usr/lib/libobjc.A.dylib
    

    4 Solutions Collect From Internet About “Xcode 7 beta 2: LaunchScreen.storyboard could not open document”

    This worked for me on El Capitan.

    Go to

    /Library/Developer/CoreSimulator/Profiles/Runtimes

    and remove the profiles in there.
    Restart Xcode and it should work!


    For Yosemite users try the following:

    • Open up terminal

    cd Library

    cd Developer

    cd Devices

    rm -rf *

    Also, you can always type ls to list the files and directories. There may be another folder such as Profiles on your machine. Not sure since I only did this on my Yosemite machine that wasn’t having issues.

    Restart Xcode, clean, build etc.

    Use sudo if there are any permission issues.

    Go to your Target/General and fix the Deployment target. I hope that this helps

    Open the LaunchScreen.storyboard in text mode and look for any anomaly.

    You can also remove it and create a new one as you only have the default UIViewController inside.

    1. Clean Project
    2. Clean derived data

    Wait for reindexing files