Xcode 9 – no iOS 11 simulator

When I open up the new Xcode 9 and go to Preferences > Components I don’t see an option to download iOS 11 simulators. I’m 100% sure I have the latest Xcode 9 beta 4 No iOS 11 sims :(

I did some research and found out that Xcode downloads an index to determine what it is able to download. For me that was:
https://devimages-cdn.apple.com/downloads/xcode/simulators/index-9.0.0-CA351AD8-3176-41CB-875C-42A05C7CDEC7.dvtdownloadableindex

  • Runtime issues with iOS 10/XCode 8
  • How to use pdfkit ios 11 to open pdf file?
  • 'hideUISearchBarWhenScrolling'-Property not working with tableView as property
  • Xcode 4.5 - CopyPNGFile persists. Need new ideas
  • UIDocumentInteractionController not working in iPad Simulator (XCode 3.2.3)
  • iOS 11 dropInteraction performDrop for files
  • Basically one is able to use it for any Xcode version by determining the DTXcoce:
    defaults read /Applications/Xcode-beta.app/Contents/Info DTXcode .
    A result like 0900 must be converted to 9.0.0

    And the DVTPlugInCompatibilityUUID:
    defaults read /Applications/Xcode-beta.app/Contents/Info DVTPlugInCompatibilityUUID

    Then download: https://devimages-cdn.apple.com/downloads/xcode/simulators/index-<the DTXcode>-<the UUID>.dvtdownloadableindex .

    And lastly in order to be able to open it: plutil -convert xml1 <the downloaded .dvtdownloadableindex file>

    Can someone verify I have the right dvtdownloadableindex? Or provide a url to the right version? Otherwise I hope someone can provide the url for the complete simulator package by downloading and cancelling the simulator while looking in to console.app like in this article

    2 Solutions Collect From Internet About “Xcode 9 – no iOS 11 simulator”

    I seem to be pretty stupid, wasting too much time than necessary.
    The new iOS 11 simulators were already included in the new Xcode, (however the won’t appear in the settings of Xcode) . You can just open up the simulator (/Applications/Xcode.app/Contents/Developer/Applications/Simulator.app) and choose an iOS 11 device in the Hardware > Device menu bar.

    Xcode.app can be Xcode-beta.app too.

    In Xcode Version 9.0 beta 5 (9M202q)

    In the menu Window > Devices and Simlators

    1. Click on the + button at the bottom left corner
    2. Choose ‘Device Type’: ‘iPhone SE’
    3. Then ‘OS Version’: ‘iOS 11.0’ can be choosen

    enter image description here

    Have fun!