Xcode build fails for react-native AwesomeProject

I’m running Xcode 4.6.3 on OS X 10.7.5. I’ve set iOS Deployment Target to 6.1 in Xcode and selected the iPhone 6.1 simulator. When I hit Run the React Packager appears and says it is ready.

Xcode then fails to build with four parse errors related to RCTImageDownloader.m and there are also nine Target Integrity warnings:

  • In Xcode how do I add a breakpoint inside a block?
  • How to remove the background of image in iphone app?
  • applicationWillTerminate not getting called on force quit of iOS app
  • How to use frameworks imported with carthage in swift playground
  • iPhone apps with a deployment target lower than 4.3 should include an armv6 architecture
  • iOS: popViewController unexpected behavior
  • /Users/SM/AwesomeProject/node_modules/react-native/Libraries/AdSupport/RCTAdSupport.xcodeproj iOS Deployment Target ‘7.0’ is newer than SDK ‘iOS 6.1’ in target RCTAdSupport

    What are my options for resolving this problem?

    Solutions Collect From Internet About “Xcode build fails for react-native AwesomeProject”

    The tools do not support building for a newer deployment target than the SDK supports. You need to lower the deployment target from 7.0 to 6.1 or use newer tools (which will require a newer version of OSX as well).